rover 25 not starting

May split into separate groups if we have enough posts
Post Reply
steven77
Posts: 7
Joined: Thu Jun 09, 2011 5:39 pm

rover 25 not starting

Post by steven77 » Thu Jun 09, 2011 5:46 pm

hi i have a rover 25 wreg been sitting for about a week now it wont start will turn over just wont start the egm is staying on when egntion is turned on and when turning over mileage flashes it is 1,4 16v wreg

cheers for any help

User avatar
paul williams
Posts: 215
Joined: Wed Sep 24, 2008 12:47 pm
Location: Telford,Shropshire
Contact:

Re: rover 25 not starting

Post by paul williams » Thu Jun 09, 2011 10:48 pm

Welcome to the forum steven77

I had a similar problem on an 800 a few years back, it turned out to be the battery. Have you checked the terminal voltage on your battery, maybe you have a substitute one? On mine I had to replace the battery and all was well.

Hope that helps

Paul Williams
1929 2 litre Coachbuilt Saloon
1951 Rover Cyclops
1958 Rover P4 90 Monte-Carlo Rally Car
1998 Discovery 300Tdi 3dr
1994 Rover 620 Sli


steven77
Posts: 7
Joined: Thu Jun 09, 2011 5:39 pm

Re: rover 25 not starting

Post by steven77 » Fri Jun 10, 2011 9:27 am

thanks no battery fine there was a buzzing noise from wee black thing that sitts behind oil cap its attchet to injector thing but at end near air box

User avatar
47p2
Posts: 694
Joined: Wed Sep 24, 2008 7:51 pm
Location: Glasgow
Contact:

Re: rover 25 not starting

Post by 47p2 » Fri Jun 10, 2011 6:59 pm

Sounds like low voltage to me

steven77
Posts: 7
Joined: Thu Jun 09, 2011 5:39 pm

Re: rover 25 not starting

Post by steven77 » Sat Jun 11, 2011 10:39 am

would that fling up egm light presst wee blavk box thing on bulk head sumeone said fuel cut of switch :?: it clickt when i presst it

when i try jump it egm staying on and mileage flashing :!:

Post Reply