Blowing oil.

Blowing oil.

Postby djm16 » Mon Nov 06, 2017 1:19 pm

Are these symptoms related?

1) on 30 C days, after about a minute of heavy throttle the engine suddenly starts blowing a huge smoke screen. It goes away instantly on easing off the throttle, and the engine continues running as normal. The temperature gauge remains on 80 C. On cooler days, nothing untoward

2) the oil pressure when the engine is warm is consistently 40 psi, except on closing the throttle on the over-run when it drops to 30 psi. Pressure is 10 psi at idle when hot. Oil is new and is HPR 15 (25W 60 Penrite).
djm16
 
Posts: 32
Joined: Sat May 07, 2016 1:28 am

Re: Blowing oil.

Postby P3Steve » Thu Jun 28, 2018 7:03 am

I had a similar problem with my P3 and found it was blowing between No. 1 piston and an oil way but you could also see a slight bubbling of oil from the join between the block and head. A new head gasket seems to have sorted it.
Other than the obvious like worn valve guides or a broken ring I don't know what else to suggest.

Edit add - as a foot note mine does seem very sensitive to timing variations which if out can cause a bit of smoke
P3Steve
 
Posts: 123
Joined: Sun Sep 28, 2008 6:05 am

Re: Blowing oil.

Postby jp928 » Sun Jul 22, 2018 8:00 am

From memory P3 pistons had their ring land at the oil drilled to let the oil go inside the piston and down, but it also allowed sump pressure to blow oil past the rings sometimes. Check that your oil breather is clear, and not building pressure when at full throttle.
jp 26 Rover 9, previously P2,P3,P4,P6,RR, Discos, Lightweight.
jp928
 
Posts: 67
Joined: Fri Aug 02, 2013 6:44 am


Return to Early post WWII, P3 the original Rover 75 and 60

Who is online

Users browsing this forum: No registered users and 0 guests