Electrical oddities

Electrical oddities

Postby MaxPegler » Sun Dec 09, 2018 12:44 am

Hi all,

Some good advice just now.

I have a strange one. Blip the throttle and the ammeter goes well into the negative. I don't know whether it's charging or not. However, turn the headlights on, and they don't dim as the throttle is given the same blip. They stay constant.

Any idea what's going on? Could the ammeter have been connected the wrong way round? What else to look for? Electrics aren't my strong point.

TIA
Max P
MaxPegler
 
Posts: 5
Joined: Tue Jul 31, 2018 10:47 pm

Re: Electrical oddities

Postby Phil - Nottingham » Thu Jan 10, 2019 10:01 pm

Possibly reversed ammeter connections - what does the ammeter do when the engine is not running and the lights are switched on? What is the state of the wiring?
P2/P4/P5/P5B/LR's - EXJ 8**/2**8MY & others
User avatar
Phil - Nottingham
 
Posts: 332
Joined: Thu Oct 09, 2008 9:45 am
Location: Nottingham

Re: Electrical oddities

Postby TonyG » Sat Jan 12, 2019 9:34 am

Max,

A month since your query was posted so you may have problem fixed. If so, let us know the outcome.

If not, I think more information is required. For example, has your car been working ok and the problem recently come about or is the issue one that exists following some work?

Phil raises the key point when he asks what state the wiring is in. If no work has been done then the ammeter is unlikely to be reversed and the problem could be in a number of places; earth connections, voltage regulator, dynamo or the loom itself. No simple or obvious solution I can think of. If the problem is following recent work then that would be the place to start looking. Always best to get back to basics and not get mis-led.

Just a thought though if you have recently got the car going- have you connected it positive or negative earth on the battery? It would originally have been positive so the ammeter would work the other way if you have connected it negative earth. Swapping the connections on the ammeter will resolve issue. If this is the case, You also need to swap over the coil connections. A bit late to re-polarise the dynamo! Worthwhile having it negative earth if that’s what has happened in case you ever want to use modern extras like a radio or sat nav.

Re wiring the car is something all owners of old cars should have on their action list so, even if you go down that route and find that the original problem was a faulty component, it will have been worthwhile anyway. Faulty wiring can cause fires and the insulation on old cables often disintegrates as soon as you touch it!

If it’s been re wired you should be able to see the cable colours easily and with the diagrams in the workshop manual check that all connections are correct. I know it can appear daunting when you peek behind the dash and see a jumble of wires but each has its own colour and the diagram shows exactly where it goes.

Good luck with it and let us know how you get on.

Tony Gilbert
Tony Gilbert

P1 12 Tourer
P2 12 6 Light Saloon
Discovery 3
Discovery Sport
TonyG
 
Posts: 42
Joined: Mon Sep 07, 2015 3:38 pm

Re: Electrical oddities

Postby MaxPegler » Mon Jan 14, 2019 4:35 am

Thanks Tony,

No this discrepancy isn't solved. The car's new to me so I don't what's been done & hasn't been done. Clearly the original loom though. Battery is positive earth. Starts easily & seems to be charging.

It's in having seatbelts fitted as we speak , when it's back I'll be more confident in driving it, will advise what we discover.

That is, if this current heat in Sydney ever subsides!

Regards
Max P
MaxPegler
 
Posts: 5
Joined: Tue Jul 31, 2018 10:47 pm


Return to Early post WWII, P3 the original Rover 75 and 60

Who is online

Users browsing this forum: No registered users and 0 guests